Welkom, Gast. Alsjeblieft inloggen of registreren.

Login met gebruikersnaam, wachtwoord en sessielengte

Auteur Topic: Voorseinen werken niet  (gelezen 372 keer)

mkasthijs

  • Jr. Member
  • **
  • Berichten: 99
Voorseinen werken niet
« Gepost op: 26 januari 2016, 01:28 »
Goedenacht (ja ik weet het, lekker laat)

Ik was eerder vanavond aan het rijden en opeens viel het mij op dat de voorseinen hun werk niet meer doen.
Later vanavond nog eens goed gekeken en getest en warempel, ze werken niet meer.
Het probleem is als volgt.
Als ik langs een voorsein rijdt aan mijn kant moet deze normaal 'geel' worden. Deze blijft groen. Pas als ik langs het sein daarop ga wordt het voorsein (wat ik al gehad heb) geel.
Andersom is het net zo.
Als ik langs het sein aan de andere kant gereden ben wordt deze groen. Maar het voorsein, waar ik later nog langs moet rijden, wordt ook direct groen. Dit probleem had ik nooit eerder en heb ook niks aan de seinen gedaan.
Ik heb al de seinen opnieuw geïnstalleerd, het cache geheugen van het spel gewist, maar wat ik ook doe, het werkt niet.
Zijn er meer van jullie die dit probleem hebben?

Alvast bedankt.

Groet mkasthijs (Matthijs)

rommy136

  • Jr. Member
  • **
  • Berichten: 60
Re: Voorseinen werken niet
« Reactie #1 Gepost op: 26 januari 2016, 08:02 »
Beste Matthijs,

Dit klopt. Zo te horen werkt het seinenpakket zoals behoren bij jou. Na een treinpassage valt namelijk een voorsein niet af maar blijft deze in de huidige stand staan. Een voorsein zegt immers alleen iets over het seinbeeld van het volgende sein. Zolang dit volgende sein veilig is zal je voorsein ook altijd een beter seinbeeld aanbieden dan geel.

Mvg Rommy

TjoeTjoe

  • Global Moderator
  • Sr. Member
  • *****
  • Berichten: 384
Re: Voorseinen werken niet
« Reactie #2 Gepost op: 26 januari 2016, 08:53 »
Matthijs,

ik snap waar de verwarring vandaan komt: in versie 1.0 was het namelijk wel zo dat een voorsein naar "geel" viel zodra de trein het voorsein passeerde.
Zelf was ik namelijk in de veronderstelling dat dit altijd gebeurde bij passage van voorseinen. Een praktijkvoorbeeld in mijn woonplaats was hier eigenlijk de basis voor.

In een later stadium ben ik door experts er op gewezen dat dit juist een uitzonderlijk geval is.
Normaliter valt een voorsein dus van "Groen" naar "Geel" op het moment dat het hoofdsein waartoe het hoort naar "Rood" valt.
Slechts in uitzonderlijke gevallen - vroeger was dit zeker het geval, weet niet of dat hedendaags nog het geval is - valt het voorsein direct naar "Geel" af bij passage hiervan.
Dus naar aanleiding van de opmerkingen uit de grote-mensen-wereld is het nu zo dat het voorsein pas van seinbeeld verandert als het bijhorende hoofdsein van seinbeeld veranderd.

Zie wel dat ik de handleiding hier nog even op aan moet passen.
Heb in overweging om het naar "Geel" vallen bij passage v.h. voorsein als toekomstige configureerbare optie in het script op te nemen, zodat ook historisch verantwoorde werking nagebootst kan worden

Erwin

mkasthijs

  • Jr. Member
  • **
  • Berichten: 99
Re: Voorseinen werken niet
« Reactie #3 Gepost op: 26 januari 2016, 09:59 »
Kijk eens aan.
Ik helemaal in paniek, omdat dat niet kon en altijd werkte en blablabla.
Paniek om niks!
Bedankt Erwin voor de duidelijke uitleg en Rommy ook.

Matthijs